login  home  contents  what's new  discussion  bug reports     help  links  subscribe  changes  refresh  edit

Submitted by : (unknown) at: 2007-11-17T22:25:59-08:00 (9 years ago)
Name :
Axiom Version :
Category : Severity : Status :
Optional subject :  
Optional comment :

Actually this problem should be fixed in main--patch-24.


The segfault is caused by an attempt to close a closed file in hypertex.
Steve Wilson and Bob McElrath cornered the problem and fixed it.


You should be able to


cd axiom--main--1--patch-23
tla update
export AXIOM=`pwd`/mnt/solaris9
export PATH=$AXIOM/bin:$PATH
make


and it should not need to rebuild the world. Of course, it never hurts
to build cleanly.


Let me know if you get it to work.


Ok, I updated and rebuilt (only what needed to be rebuilt).


The result is that I have hypertex, which appears to work.  At least I can run the 
"hypertex"
command, and I can browse, and the graphics work. (The mouse seems to be
over-accelerated, but that's a detail.)


However,


(1) I can't get hypertex to connect to the Axiom server.  I get:


(HyperDoc) Warning: Not connected to AXIOM Server!


I have AXIOM and PATH set correctly.


(2) If I run "axiom -ht -go" I get (I've done "set -x" at the top of the axiom 
script)
...
+ exec /home/build/axiom--main--1--patch-23/mnt/sol9gcc/bin/sman -ht -ws 
/home/build/axiom--main--1--patch-23/mnt/sol9gcc/bin/AXIOMsys
fork_Axiom: Failed to reopen server: No such file or directory
clef trying to get the initial terminal settings: Invalid argument


(3) The command "sman -debug -noclef -nonag -noht" still dumps core:


bash-2.05$ sman -debug -noclef -nonag -noht
  sman -noclef -gr -nonag -noht -noiw -ihere -ihere -ws '$AXIOM/bin/AXIOMsys' 
-grprog '$AXIOM/lib/viewman' -nagprog '$AXIOM/lib/nagman' -htprog 
'$AXIOM/bin/hypertex -s' -clefprog '' -sessionprog '$AXIOM/lib/session' 
-clientprog '$AXIOM/lib/spadclient' -rm Segmentation Fault (core dumped)
bash-2.05$




  Subject:   Be Bold !!
  ( 13 subscribers )  
Please rate this page: